Kiosk Update Interruption
Incident Report for Visitu
Resolved
This incident has been resolved.
Posted Oct 05, 2022 - 19:47 UTC
Monitoring
A fix has been deployed and we are continuing to monitor for ongoing issues.
Posted Oct 05, 2022 - 16:37 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 05, 2022 - 16:31 UTC